chef-16.4.35.gem

STEP 1: Have you installed this repository?

If not, run this installation script command:

curl -s https://packagecloud.io/install/repositories/cinc-project/stable/script.gem.sh | bash
copy
curl -s https://packagecloud.io/install/repositories/cinc-project/stable/script.gem.sh | bash

STEP 2: Install the package
sudo gem install chef -v=16.4.35

A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure.

Checksums

MD5 3eb621bf3c3a0ef5c06dbac960160f43
SHA1 334015bf47ee64ae92421b03b6b5a7065a349afc
SHA256 08a94d639236a5f257175c77a73046ed30a2f1c70007e0510e835455421e3c40
SHA512 ca76a806724fedf216daa69e7b8977658e908e037783188c195ee1579d6bf3c8e446e3c5e268d6e6a7c9e8958921d47271bf8f00b0aae8bfbec5da5df4d3b9f4

Runtime Dependencies

  • chef-config (= 16.4.35)
  • chef-utils (= 16.4.35)
  • train-core (~> 3.2, >= 3.2.28)
  • train-winrm (>= 0.2.5)
  • license-acceptance (~> 1.0, >= 1.0.5)
  • mixlib-cli (>= 2.1.1, < 3.0)
  • mixlib-log (>= 2.0.3, < 4.0)
  • mixlib-authentication (>= 2.1, < 4)
  • mixlib-shellout (>= 3.1.1, < 4.0)
  • mixlib-archive (>= 0.4, < 2.0)
  • ohai (~> 16.0)
  • ffi (>= 1.9.25)
  • ffi-yajl (~> 2.2)
  • net-ssh (>= 4.2, < 7)
  • net-ssh-multi (~> 1.2, >= 1.2.1)
  • net-sftp (>= 2.1.2, < 4.0)
  • ed25519 (~> 1.2)
  • bcrypt_pbkdf (= 1.1.0.rc1)
  • highline (>= 1.6.9, < 3)
  • tty-prompt (~> 0.21)
  • tty-screen (~> 0.6)
  • pastel (>= 0)
  • erubis (~> 2.7)
  • diff-lcs (>= 1.2.4, < 1.4.0)
  • ffi-libarchive (~> 1.0, >= 1.0.3)
  • chef-zero (>= 14.0.11)
  • chef-vault (>= 0)
  • plist (~> 3.2)
  • iniparse (~> 1.4)
  • addressable (>= 0)
  • syslog-logger (~> 1.6)
  • uuidtools (~> 2.1.5)
  • proxifier (~> 1.0)
  • bundler (>= 1.10)

Files

  • tasks/rspec.rb
  • spec/unit/windows_service_spec.rb
  • spec/unit/win32/security_spec.rb
  • spec/unit/win32/registry_spec.rb
  • spec/unit/win32/link_spec.rb
  • spec/unit/win32/error_spec.rb
  • spec/unit/version/platform_spec.rb
  • spec/unit/version_string_spec.rb
  • spec/unit/version_constraint/platform_spec.rb
  • spec/unit/version_constraint_spec.rb
  • spec/unit/version_class_spec.rb
  • spec/unit/util/windows/logon_session_spec.rb
  • spec/unit/util/threaded_job_queue_spec.rb
  • spec/unit/util/selinux_spec.rb
  • spec/unit/util/powershell/ps_credential_spec.rb
  • spec/unit/util/powershell/cmdlet_spec.rb
  • spec/unit/util/file_edit_spec.rb
  • spec/unit/util/editor_spec.rb
  • spec/unit/util/dsc/resource_store.rb
  • spec/unit/util/dsc/local_configuration_manager_spec.rb
  • spec/unit/util/dsc/lcm_output_parser_spec.rb
  • spec/unit/util/dsc/configuration_generator_spec.rb
  • spec/unit/util/diff_spec.rb
  • spec/unit/util/backup_spec.rb
  • spec/unit/user_v1_spec.rb
  • spec/unit/user_spec.rb
  • spec/unit/train_transport_spec.rb
  • spec/unit/shell/shell_session_spec.rb
  • spec/unit/shell/shell_ext_spec.rb
  • spec/unit/shell/model_wrapper_spec.rb

Uploaded

almost 4 years ago

Package Size

1.78 MB

Downloads

62

wget

wget --content-disposition "https://packagecloud.io/cinc-project/stable/packages/gems/chef-16.4.35.gem/download.gem?distro_version_id=rubygem"

Homepage

https://www.chef.io