erlang-18.3.4-1.el7.centos.x86_64.rpm

General-purpose programming language and runtime environment

{{expandedText}} full description
This is a minimal packaging of Erlang produced by Pivotal to support
running RabbitMQ. Compared to the community Erlang packaging it is
monolithic, has fewer dependencies, and has lower disk and memory
overhead. Many applications from Erlang Open Telecom Platform (OTP)
have been removed. The following applications remain: asn1, compiler,
crypto, erl_interface, erts, hipe, inets, kernel, mnesia, os_mon,
otp_mibs, public_key, reltool, runtime_tools, sasl, snmp, ssl, stdlib,
syntax_tools and xmerl.
size 17.5 MB downloads 163 uploaded over 1 year ago

Install the repository -
    
  

curl -s https://packagecloud.io/install/repositories/rabbitmq/erlang/script.rpm.sh | sudo bash
sudo yum install erlang-18.3.4-1.el7.centos.x86_64

Copy the script tag and include it in your HTML. Place the script tag where you want these instructions to appear.

The embeded script will look like this on your website:

curl -s https://packagecloud.io/install/repositories/rabbitmq/erlang/script.rpm.sh | sudo bash
sudo yum install erlang-18.3.4-1.el7.centos.x86_64

Download the package

Download Statistics

Checksums

MD5 355919a5d5ea3e1603e703076c4906ab
SHA1 fe2c90c8a2bad055c0c05012c729370e26478f8a
SHA256 02093e0adbb480a62931b86ca77e68b763c96fcea7fcb48c5503cab39a8684bb

Files

  • /usr/lib64/erlang/lib/syntax_tools-1.7/ebin/erl_recomment.beam
  • /usr/lib64/erlang/lib/syntax_tools-1.7/ebin/erl_prettypr.beam
  • /usr/lib64/erlang/lib/syntax_tools-1.7/ebin/erl_comment_scan.beam
  • /usr/lib64/erlang/lib/syntax_tools-1.7/ebin/epp_dodger.beam
  • /usr/lib64/erlang/lib/stdlib-2.8/src/dets.hrl
  • /usr/lib64/erlang/lib/stdlib-2.8/include/zip.hrl
  • /usr/lib64/erlang/lib/stdlib-2.8/include/qlc.hrl
  • /usr/lib64/erlang/lib/stdlib-2.8/include/ms_transform.hrl
  • /usr/lib64/erlang/lib/stdlib-2.8/include/erl_compile.hrl
  • /usr/lib64/erlang/lib/stdlib-2.8/include/erl_bits.hrl
  • /usr/lib64/erlang/lib/stdlib-2.8/include/assert.hrl
  • /usr/lib64/erlang/lib/stdlib-2.8/ebin/zip.beam
  • /usr/lib64/erlang/lib/stdlib-2.8/ebin/win32reg.beam
  • /usr/lib64/erlang/lib/stdlib-2.8/ebin/unicode.beam
  • /usr/lib64/erlang/lib/stdlib-2.8/ebin/timer.beam
  • /usr/lib64/erlang/lib/stdlib-2.8/ebin/sys.beam
  • /usr/lib64/erlang/lib/stdlib-2.8/ebin/supervisor.beam
  • /usr/lib64/erlang/lib/stdlib-2.8/ebin/supervisor_bridge.beam
  • /usr/lib64/erlang/lib/stdlib-2.8/ebin/string.beam
  • /usr/lib64/erlang/lib/stdlib-2.8/ebin/stdlib.appup
  • /usr/lib64/erlang/lib/stdlib-2.8/ebin/stdlib.app
  • /usr/lib64/erlang/lib/stdlib-2.8/ebin/sofs.beam
  • /usr/lib64/erlang/lib/stdlib-2.8/ebin/slave.beam
  • /usr/lib64/erlang/lib/stdlib-2.8/ebin/shell.beam
  • /usr/lib64/erlang/lib/stdlib-2.8/ebin/shell_default.beam
  • /usr/lib64/erlang/lib/stdlib-2.8/ebin/sets.beam
  • /usr/lib64/erlang/lib/stdlib-2.8/ebin/re.beam
  • /usr/lib64/erlang/lib/stdlib-2.8/ebin/random.beam
  • /usr/lib64/erlang/lib/stdlib-2.8/ebin/rand.beam
  • /usr/lib64/erlang/lib/stdlib-2.8/ebin/queue.beam

Requires

  • /bin/sh
  • /usr/bin/env
  • libc.so.6(GLIBC_2.15)(64bit)
  • libcrypto.so.10()(64bit)
  • libcrypto.so.10(OPENSSL_1.0.1)(64bit)
  • libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit)
  • libcrypto.so.10(libcrypto.so.10)(64bit)
  • libdl.so.2()(64bit)
  • libdl.so.2(GLIBC_2.2.5)(64bit)
  • libm.so.6()(64bit)
  • libm.so.6(GLIBC_2.2.5)(64bit)
  • libnsl.so.1()(64bit)
  • libpthread.so.0()(64bit)
  • libpthread.so.0(GLIBC_2.12)(64bit)
  • libpthread.so.0(GLIBC_2.2.5)(64bit)
  • libpthread.so.0(GLIBC_2.3.2)(64bit)
  • libresolv.so.2()(64bit)
  • librt.so.1()(64bit)
  • librt.so.1(GLIBC_2.2.5)(64bit)
  • libtinfo.so.5()(64bit)
  • libutil.so.1()(64bit)
  • libutil.so.1(GLIBC_2.2.5)(64bit)
  • libz.so.1()(64bit)
  • libz.so.1(ZLIB_1.2.2)(64bit)
  • rtld(GNU_HASH)

Provides

  • erlang(x86-64) = 18.3.4-1.el7.centos
  • erlang
  • erlang = 18.3.4-1.el7.centos