erlang-19.1.5-1.el6.x86_64.rpm

General-purpose programming language and runtime environment

Full description:
This is a minimal packaging of Erlang produced by Pivotal to support
running RabbitMQ. Compared to the community Erlang packaging it is
monolithic, has fewer dependencies, and has lower disk and memory
overhead. Many applications from Erlang Open Telecom Platform (OTP)
have been removed. The following applications remain: asn1, compiler,
crypto, erl_interface, erts, hipe, inets, kernel, mnesia, os_mon,
otp_mibs, public_key, reltool, runtime_tools, sasl, snmp, ssl, stdlib,
syntax_tools and xmerl.

Checksums

MD5 405e7e9810741d986ba5597ed5889b93
SHA1 754655101909c72a72158aa518d555faf2f78127
SHA256 271b2d297f78e932829ca1ddfd3b8c2dedbc2b65cb47d1e365dd22aa10722c89
SHA512 bc81728b39c2c041d1d4d54225fe309cc7f64126781ef5aa8810cef99962e3b0d96326a9dec666ad54d54839fae0ce1dc4fac1c4dffdb4f887ad67226389bd4c

Requires

  • /bin/sh
  • /usr/bin/env
  • libc.so.6(GLIBC_2.11)(64bit)
  • libcrypto.so.10()(64bit)
  • libcrypto.so.10(OPENSSL_1.0.1)(64bit)
  • libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit)
  • libcrypto.so.10(libcrypto.so.10)(64bit)
  • libdl.so.2()(64bit)
  • libdl.so.2(GLIBC_2.2.5)(64bit)
  • libm.so.6()(64bit)
  • libm.so.6(GLIBC_2.2.5)(64bit)
  • libnsl.so.1()(64bit)
  • libpthread.so.0()(64bit)
  • libpthread.so.0(GLIBC_2.12)(64bit)
  • libpthread.so.0(GLIBC_2.2.5)(64bit)
  • libpthread.so.0(GLIBC_2.3.2)(64bit)
  • libresolv.so.2()(64bit)
  • librt.so.1()(64bit)
  • librt.so.1(GLIBC_2.2.5)(64bit)
  • libtinfo.so.5()(64bit)
  • libutil.so.1()(64bit)
  • libutil.so.1(GLIBC_2.2.5)(64bit)
  • rtld(GNU_HASH)

Provides

  • asn1rt_nif.so()(64bit)
  • crypto.so()(64bit)
  • crypto_callback.so()(64bit)
  • dyntrace.so()(64bit)
  • erlang(x86-64) = 19.1.5-1.el6
  • erlang
  • erlang = 19.1.5-1.el6
  • trace_file_drv.so()(64bit)
  • trace_ip_drv.so()(64bit)

Files

  • /usr/lib64/erlang/erts-8.1/include/internal/ethr_mutex.h
  • /usr/lib64/erlang/erts-8.1/include/internal/ethr_atomics.h
  • /usr/lib64/erlang/erts-8.1/include/internal/erts_internal.mk
  • /usr/lib64/erlang/erts-8.1/include/internal/erl_printf.h
  • /usr/lib64/erlang/erts-8.1/include/internal/erl_printf_format.h
  • /usr/lib64/erlang/erts-8.1/include/internal/erl_misc_utils.h
  • /usr/lib64/erlang/erts-8.1/include/internal/erl_memory_trace_protocol.h
  • /usr/lib64/erlang/erts-8.1/include/internal/erl_errno.h
  • /usr/lib64/erlang/erts-8.1/include/erl_nif.h
  • /usr/lib64/erlang/erts-8.1/include/erl_nif_api_funcs.h
  • /usr/lib64/erlang/erts-8.1/include/erl_memory_trace_parser.h
  • /usr/lib64/erlang/erts-8.1/include/erl_int_sizes_config.h
  • /usr/lib64/erlang/erts-8.1/include/erl_fixed_size_int_types.h
  • /usr/lib64/erlang/erts-8.1/include/erl_drv_nif.h
  • /usr/lib64/erlang/erts-8.1/include/erl_driver.h
  • /usr/lib64/erlang/erts-8.1/include/driver_int.h
  • /usr/lib64/erlang/erts-8.1/bin/to_erl
  • /usr/lib64/erlang/erts-8.1/bin/start.src
  • /usr/lib64/erlang/erts-8.1/bin/start_erl.src
  • /usr/lib64/erlang/erts-8.1/bin/start
  • /usr/lib64/erlang/erts-8.1/bin/run_erl
  • /usr/lib64/erlang/erts-8.1/bin/inet_gethost
  • /usr/lib64/erlang/erts-8.1/bin/heart
  • /usr/lib64/erlang/erts-8.1/bin/escript
  • /usr/lib64/erlang/erts-8.1/bin/erlexec
  • /usr/lib64/erlang/erts-8.1/bin/erlc
  • /usr/lib64/erlang/erts-8.1/bin/erl.src
  • /usr/lib64/erlang/erts-8.1/bin/erl_child_setup
  • /usr/lib64/erlang/erts-8.1/bin/erl
  • /usr/lib64/erlang/erts-8.1/bin/epmd
Have you installed this repository?

If not, run the installation script, or manually install the repository before installing this package

curl -s https://packagecloud.io/install/repositories/rabbitmq/erlang/script.rpm.sh | sudo bash
copy
curl -s https://packagecloud.io/install/repositories/rabbitmq/erlang/script.rpm.sh

Install

sudo yum install erlang-19.1.5-1.el6.x86_64

Uploaded

about 2 years ago

Package Size

17.8 MB

Installed Size

32.4 MB

Downloads

155

wget

wget --content-disposition https://packagecloud.io/rabbitmq/erlang/packages/el/6/erlang-19.1.5-1.el6.x86_64.rpm/download.rpm

Homepage

http://www.erlang.org

License

ERPL