erlang-19.1.0-1.el6.x86_64.rpm

General-purpose programming language and runtime environment

Full description:
This is a minimal packaging of Erlang produced by Pivotal to support
running RabbitMQ. Compared to the community Erlang packaging it is
monolithic, has fewer dependencies, and has lower disk and memory
overhead. Many applications from Erlang Open Telecom Platform (OTP)
have been removed. The following applications remain: asn1, compiler,
crypto, erl_interface, erts, hipe, inets, kernel, mnesia, os_mon,
otp_mibs, public_key, reltool, runtime_tools, sasl, snmp, ssl, stdlib,
syntax_tools and xmerl.

Checksums

MD5 271f681ff2359c3d8881e2155340cc59
SHA1 2b9cf16177806ba0ce169a8c2bd72ae8fc8c4b0f
SHA256 49c09ef67aaf5738a6bc39784d485418f9e3adab23b16ef3107cc4fdf51793be
SHA512 4b44e0f874225842006b33c74dd698a4e8500ef5c1057bb028210df19cd961d3eb7f117b404d02fed6ffeff4b2cf49bf7cf09695d2f2dcf16848b37cc8fd8f0c

Requires

  • /bin/sh
  • /usr/bin/env
  • libc.so.6(GLIBC_2.11)(64bit)
  • libcrypto.so.10()(64bit)
  • libcrypto.so.10(OPENSSL_1.0.1)(64bit)
  • libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit)
  • libcrypto.so.10(libcrypto.so.10)(64bit)
  • libdl.so.2()(64bit)
  • libdl.so.2(GLIBC_2.2.5)(64bit)
  • libm.so.6()(64bit)
  • libm.so.6(GLIBC_2.2.5)(64bit)
  • libnsl.so.1()(64bit)
  • libpthread.so.0()(64bit)
  • libpthread.so.0(GLIBC_2.12)(64bit)
  • libpthread.so.0(GLIBC_2.2.5)(64bit)
  • libpthread.so.0(GLIBC_2.3.2)(64bit)
  • libresolv.so.2()(64bit)
  • librt.so.1()(64bit)
  • librt.so.1(GLIBC_2.2.5)(64bit)
  • libtinfo.so.5()(64bit)
  • libutil.so.1()(64bit)
  • libutil.so.1(GLIBC_2.2.5)(64bit)
  • rtld(GNU_HASH)

Provides

  • asn1rt_nif.so()(64bit)
  • crypto.so()(64bit)
  • crypto_callback.so()(64bit)
  • dyntrace.so()(64bit)
  • erlang(x86-64) = 19.1.0-1.el6
  • erlang
  • erlang = 19.1.0-1.el6
  • trace_file_drv.so()(64bit)
  • trace_ip_drv.so()(64bit)

Files

  • /usr/share/doc/erlang-19.1.0/Erlang_ASL2_LICENSE.txt
  • /usr/lib64/erlang/usr/lib/liberts.a
  • /usr/lib64/erlang/usr/lib/liberts_r.a
  • /usr/lib64/erlang/usr/lib/liberl_interface.a
  • /usr/lib64/erlang/usr/lib/liberl_interface_st.a
  • /usr/lib64/erlang/usr/lib/libei.a
  • /usr/lib64/erlang/usr/lib/libei_st.a
  • /usr/lib64/erlang/usr/include/erl_nif.h
  • /usr/lib64/erlang/usr/include/erl_nif_api_funcs.h
  • /usr/lib64/erlang/usr/include/erl_memory_trace_parser.h
  • /usr/lib64/erlang/usr/include/erl_interface.h
  • /usr/lib64/erlang/usr/include/erl_int_sizes_config.h
  • /usr/lib64/erlang/usr/include/erl_fixed_size_int_types.h
  • /usr/lib64/erlang/usr/include/erl_drv_nif.h
  • /usr/lib64/erlang/usr/include/erl_driver.h
  • /usr/lib64/erlang/usr/include/eicode.h
  • /usr/lib64/erlang/usr/include/ei.h
  • /usr/lib64/erlang/usr/include/ei_connect.h
  • /usr/lib64/erlang/usr/include/driver_int.h
  • /usr/lib64/erlang/releases/start_erl.data
  • /usr/lib64/erlang/releases/RELEASES.src
  • /usr/lib64/erlang/releases/RELEASES
  • /usr/lib64/erlang/releases/19/start.script
  • /usr/lib64/erlang/releases/19/start.boot
  • /usr/lib64/erlang/releases/19/start_sasl.script
  • /usr/lib64/erlang/releases/19/start_sasl.rel
  • /usr/lib64/erlang/releases/19/start_sasl.boot
  • /usr/lib64/erlang/releases/19/start_clean.script
  • /usr/lib64/erlang/releases/19/start_clean.rel
  • /usr/lib64/erlang/releases/19/start_clean.boot
Have you installed this repository?

If not, run the installation script, or manually install the repository before installing this package

curl -s https://packagecloud.io/install/repositories/rabbitmq/erlang/script.rpm.sh | sudo bash
copy
curl -s https://packagecloud.io/install/repositories/rabbitmq/erlang/script.rpm.sh

Install

sudo yum install erlang-19.1.0-1.el6.x86_64

Uploaded

about 2 years ago

Package Size

17.8 MB

Installed Size

32.4 MB

Downloads

119

wget

wget --content-disposition https://packagecloud.io/rabbitmq/erlang/packages/el/6/erlang-19.1.0-1.el6.x86_64.rpm/download.rpm

Homepage

http://www.erlang.org

License

ERPL